Cisco Router DHCP Server + NAT + VLAN

This to configure :

– Cisco Router as DHCP server
– NAT Configuration
– VLAN

Scenario : Private IP on VLANs assigned by Cisco Router DHCP and NATed to Public.

ip subnet-zero
ip domain-name indo.net.id
ip name-server 202.53.253.65
no ip dhcp conflict logging
ip dhcp excluded-address 10.0.0.1
ip dhcp excluded-address 10.0.1.1


!
ip dhcp pool NOC
network 10.0.0.0 255.255.255.0
domain-name meg-gepper.eldo.indo.net.id
dns-server 202.53.251.17
default-router 10.0.0.1
netbios-node-type h-node
!
ip dhcp pool SMC
network 10.0.1.0 255.255.255.0
domain-name betmen.eldo.indo.net.id
dns-server 202.53.251.17
default-router 10.0.1.1
netbios-node-type h-node
!
lane client flush
!
interface FastEthernet0/0
description Trunk
no ip address
full-duplex
!
interface FastEthernet0/0.1
description to LAN-ELDO-OUTSIDE
encapsulation isl 1
ip address 192.168.1.1 255.255.255.252 secondary
ip address 172.16.0.24 255.255.0.0
no ip redirects
ip nat outside
!
interface FastEthernet0/0.2
description to PRIVATE-SMC
encapsulation isl 2
ip address 10.0.1.1 255.255.255.0
no ip redirects
ip nat inside
!
interface FastEthernet0/0.3
description to PRIVATE-NOC
encapsulation isl 3
ip address 10.0.0.1 255.255.255.0
no ip redirects
ip nat inside
!
interface FastEthernet2/0
ip address 10.0.0.1 255.255.255.0
shutdown
full-duplex
!
ip nat pool meg-gepper 172.16.0.24 172.16.0.24 netmask 255.255.0.0
ip nat inside source list 1 pool meg-gepper overload
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1
no ip http server
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 10.0.1.0 0.0.0.255

Dari http://risnaini.wordpress.com

About ngengeh

Nama gw ndry

Posted on August 6, 2008, in Belajar, Cisco. Bookmark the permalink. 1 Comment.

  1. I believe this is one of the such a lot significant information for me. And i’m glad reading your article. But wanna commentary on few normal things, The website taste is ideal, the articles is actually great : D. Good job, cheers

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: